konfigurasi IP Address, Gateway, Masqureade dan Name Server di MikroTik

Sebelum melakukan konfigurasi, pastikan bahwa Mikrotik sdh trinstall dgn baik, interface juga dah dipasang. Scara standar, konfigurasi Mikrotik bisa dlakukan dgn dua mode, yaitu mode text/console dan mode GUI (via Browser dan WinBox). Tp utk lbh memahami trhdp OS ini (menurut penulis:red), kita coba konfigurasi dengan console.

Pertama hidupkan Mikrotik, lalu kita akan dhadapkn dgn login masuk kesistem.

1) Masukkan username & password, dalam hal ini karena masih baru maka default username : admin password : blank

[admin@Mikrotik] > interface print

Flags: X – disabled, D – dynamic, R – running

# NAME TYPE RX-RATE TX-RATE MTU

0 R ether1 ether 0 0 1500

1 R ether2 ether 0 0 1500

[admin@Mikrotik]>

Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi
etherned cardnya, seharusnya R (running).

  • Mengganti nama interface

[admin@Mikrotik] > interface(enter)

  • Untuk mengganti nama Interface ether1 menjadi Public (atau terserah namanya), maka

[admin@Mikrotik] interface> set 0 name=Public

  • Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka

[admin@Mikrotik] interface> set 1 name=Local

  • Atau langsung saja dari posisi root direktori, memakai tanda “/”, tanpa tanda kutip

[admin@Mikrotik] > /interface set 0 name=Public

  • Cek lagi apakah nama interface sudah diganti.

[admin@Mikrotik] > /interface print

Flags: X – disabled, D – dynamic, R – running

# NAME TYPE RX-RATE TX-RATE MTU

0 R Local ether 0 0 1500

1 R Public ether 0 0 1500

2) Mengganti password default

Untuk keamanan ganti password default

[admin@Mikrotik] > password

old password: *****

new password: *****

retype new password: *****

[admin@ Mikrotik]]>

3) Mengganti nama hostname

Mengganti nama Mikrotik Router untuk memudahkan konfigurasi, pada langkah ini nama server akan diganti menjadi “heroe”

[admin@Mikrotik] > system identity set name=heroe

[admin@heroe]>

4) Setting IP Address, Gateway, Masqureade dan Name Server

4.1) IP Address

Bentuk Perintah konfigurasi

ip address add address ={ip address/netmask} interface={nama interface}

  • Memberikan IP address pada interface Mikrotik. Misalkan Public akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.1.2 dan Local akan kita gunakan untuk network LAN kita dengan IP 192.168.0.30.

[admin@heroe] > ip address add address=192.168.1.2 \netmask=255.255.255.0 interface=Public comment=”IP ke Internet”

[admin@heroe] > ip address add address=192.168.0.30 \netmask=255.255.255.224 interface=Local comment = “IP ke LAN”

  • Melihat konfigurasi IP address yang sudah kita berikan

[admin@heroe] >ip address print

Flags: X – disabled, I – invalid, D – dynamic

# ADDRESS NETWORK BROADCAST INTERFACE

0 ;;; IP Address ke Internet 192.168.0.30/27 192.168.0.0 192.168.0.31 Local

1 ;;; IP Address ke LAN 192.168.1.2/24 192.168.0.0 192.168.1.255 Public

[admin@heroe]>

4.2) Gateway

Bentuk Perintah Konfigurasi

ip route add gateway={ip gateway}

  • Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.1.1

[admin@heroe] > /ip route add gateway=192.168.1.1

  • Melihat Tabel routing pada Mikrotik Routers

[admin@heroe] > ip route print

Flags: X – disabled, A – active, D – dynamic, C – connect, S – static, r – rip, b – bgp, o – ospf

# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE

0 ADC 192.168.0.0/24 192.168.0.30 Local

1 ADC 192.168.0.0/27 192.168.1.2 Public

2 A S 0.0.0.0/0 r 192.168.1.1 Public

[admin@heroe]>

  • Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

[admin@heroe] > ping 192.168.1.1

192.168.1.1 64 byte ping: ttl=64 time<1 ttl=”64″ max =” 0/0.0/0″>

4.3) NAT (Network Address Translation)

Bentuk Perintah Konfigurasi

ip firewall nat add chain=srcnat action=masquerade out-inteface={ethernet yang langsung terhubung ke Internet atau Public}

  • Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.

[admin@heroe] > ip firewall nat add chain=scrnat out-interface=Public action=masquerade

[admin@heroe]>

  • Melihat konfigurasi Masquerading

[admin@heroe] ip firewall nat print

Flags: X – disabled, I – invalid, D – dynamic

0 chain=srcnat out-interface=Public action=masquerade

[admin@heroe]>

4.4) Name server

Bentuk Perintah Konfigurasi

ip dns set primary-dns={dns utama} secondary-dns={dns ke dua}

  • Setup DNS pada Mikrotik Routers, misalkan DNS dengan Ip Addressnya Primary = 202.134.0.155, Secondary = 202.134.2.5

[admin@heroe] > ip dns set primary-dns=202.134.0.155 allow-remoterequests=yes

[admin@heroe] > ip dns set secondary-dns=202.134.2.5 allow-remoterequests=yes

  • Melihat konfigurasi DNS

[admin@heroe] > ip dns print

primary-dns: 202.134.0.155

secondary-dns: 202.134.2.5

allow-remote-requests: no

cache-size: 2048KiB

cache-max-ttl: 1w

cache-used: 16KiB

[admin@heroe]>

  • Tes untuk akses domain, misalnya dengan ping nama domain

[admin@heroe] > ping yahoo.com

216.109.112.135 64 byte ping: ttl=48 time=250 ms

10 packets transmitted, 10 packets received, 0% packet loss

round-trip min/avg/max = 571/571.0/571 ms

[admin@heroe]>

Jika sudah berhasil reply berarti seting DNS sudah benar.

  • Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup DHCP server pada Mikrotik. Berikut langkah-langkahnya :

Buat IP address pool

/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

  • Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client. Pada kerja praktik ini networknya adalah 172.16.0.0/24 dan gatewaynya 172.16.0.1

/ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

  • Tambahkan DHCP Server ( pada kerja praktik ini DHCP diterapkan pada interface ether2/local )

/ip dhcp-server add interface=local address-pool=dhcp-pool

  • Lihat status DHCP server

[admin@Waton] > ip dhcp-server print

Flags: X – disabled, I – invalid

# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP

0 X dhcp1 local

Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah 5.

  • Jangan Lupa dibuat enable dulu DHCP servernya

/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif.

  • Tes Dari client.

Sampai disini, client sdh bisa terhubung dengan internet, namun masih dgn kabel. Jika ingin membuat Hotspot, perlu ada konfigurasi lagi. InsyaAllah next post…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s