Cara Konfigurasi Basic VLAN pada Cisco Switch dan Router

VLAN merupakan suatu model jaringan yang tidak terbatas pada lokasi fisik seperti LAN , hal ini mengakibatkan suatu network dapat dikonfigurasi secara virtual tanpa harus menuruti lokasi fisik peralatan.  Penggunaan VLAN akan membuat pengaturan jaringan menjadi sangat fleksibel dimana dapat dibuat segmen yang bergantung pada organisasi atau departemen, tanpa bergantung pada lokasi workstation. Atau bisa dibaca pada wikipedia.

Kali ini, saya akan mencoba membuat sebuah jaringan komputer menggunakan VLAN memakai software simulator Packet Tracer dengan topologi seperti pada gambar dibawah ini:

vlan

basic VLAN

 

Persiapan

Pada topologi diatas, terdapat:

1. 3 buah PC dengan detail:

  • PC1

IP: 192.168.1.3

GW: 192.168.1.1

Vlan: 100

Connect to: Port 1 SW1

  • PC2

IP: 192.168.2.3

GW: 192.168.2.1

Vlan: 200

Connect to: Port 2 SW1

  • PC3

IP: 192.168.3.3

GW: 192.168.3.1

Vlan: 300

Connect to: Port 3 SW1

2. 1  Buah Managable Switch 2960-24TT

Connect to: Port GigaEthernet 0/1 pada RT1

3. 1 Buah Router 2911

Konfigurasi

Langkah pertama, buat topologi seperti pada gambar diatas.

Selanjutnya, configurasi SW1:

Klik pada SW1, buka CLI dan ketik configurasi berikut:

SW1>en
SW1#configure terminal
SW1(config)#vlan 100
SW1(config-vlan)#name IT
SW1(config-vlan)#exit
SW1(config)#vlan 200
SW1(config-vlan)#name Marketing
SW1(config-vlan)#exit
SW1(config)#vlan 300
SW1(config-vlan)#name Import
SW1(config-vlan)#exit
SW1(config)#interface fastEthernet0/1
SW1(config-if)#no shutdown
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 100
SW1(config-if)#exit
SW1(config)#interface fastEthernet0/2
SW1(config-if)#no shutdown
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 200
SW1(config-if)#exit
SW1(config)#interface fastEthernet0/3
SW1(config-if)#no shutdown
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 300
SW1(config-if)#exit
SW1(config)#interface gigabitEthernet 0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan add 100
SW1(config-if)#switchport trunk allowed vlan add 200
SW1(config-if)#switchport trunk allowed vlan add 300
SW1(config-if)#end
SW1#
%SYS-5-CONFIG_I: Configured from console by console
SW1#

Configurasi Switch sudah selesai, selanjutnya configurasi Router:

RT1>en
RT1#configure terminal
RT1(config)#interface gigabitEthernet0/1
RT1(config-if)#no shutdown
RT1(config-if)#exit
RT1(config)#interface gigabitEthernet0/1.100
RT1(config-subif)#encapsulation dot1q vlan 100
RT1(config-subif)#ip address 192.168.1.1 255.255.255.0
RT1(config-subif)#no shutdown
RT1(config-subif)#exit
RT1(config)#interface gigabitEthernet0/1.200
RT1(config-subif)#encapsulation dot1q vlan 200
RT1(config-subif)#ip address 192.168.2.1 255.255.255.0
RT1(config-subif)#no shutdown
RT1(config-subif)#exit
RT1(config)#interface gigabitEthernet0/1.300
RT1(config-subif)#encapsulation dot1q vlan 300
RT1(config-subif)#ip address 192.168.3.1 255.255.255.0
RT1(config-subif)#no shutdown
RT1(config-subif)#exit
RT1(config)#ip routing
RT1(config)#end
RT1#show running-config
Building configuration…

Current configuration : 1013 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RT1
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524QE2P
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.100
encapsulation dot1Q 100
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/1.200
encapsulation dot1Q 200
ip address 192.168.2.1 255.255.255.0
!
interface GigabitEthernet0/1.300
encapsulation dot1Q 300
ip address 192.168.3.1 255.255.255.0
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
login
!
line aux 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
RT1#

Configurasi Router juga sudah selesai, sekarang kita test dari PC:

Packet Tracer PC Command Line 1.0
PC>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Reply from 192.168.1.1: bytes=32 time=20ms TTL=255
Reply from 192.168.1.1: bytes=32 time=10ms TTL=255
Reply from 192.168.1.1: bytes=32 time=0ms TTL=255
Reply from 192.168.1.1: bytes=32 time=0ms TTL=255

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 20ms, Average = 7ms

PC>ping 192.168.2.1

Pinging 192.168.2.1 with 32 bytes of data:

Reply from 192.168.2.1: bytes=32 time=0ms TTL=255
Reply from 192.168.2.1: bytes=32 time=0ms TTL=255
Reply from 192.168.2.1: bytes=32 time=0ms TTL=255
Reply from 192.168.2.1: bytes=32 time=1ms TTL=255

Ping statistics for 192.168.2.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

PC>ping 192.168.2.3

Pinging 192.168.2.3 with 32 bytes of data:

Reply from 192.168.2.3: bytes=32 time=1ms TTL=127
Reply from 192.168.2.3: bytes=32 time=0ms TTL=127
Reply from 192.168.2.3: bytes=32 time=0ms TTL=127
Reply from 192.168.2.3: bytes=32 time=0ms TTL=127

Ping statistics for 192.168.2.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address………: FE80::202:16FF:FEB6:DB3E
IP Address………………….: 192.168.1.3
Subnet Mask…………………: 255.255.255.0
Default Gateway……………..: 192.168.1.1

PC>

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s